Webflow export not authorized

Hello, I have followed Aron Korenbilt’s Webflow page rank tutorial 6 times now, and reached out to him via his website, but I have had no luck with getting the export to Webflow to authorize. I have tried Bearer Token, as he uses in the tutorial, I have tried 0-auth, and I have tried password, and I keep getting a 401 error. All the imports are working, from Webflow and Google Analytics, the filter sort is working, everything works until I publish and run it!

Earlier I was getting a 404 error, because Parabola has updated the flows since Aron’s tutorial was created two months ago and it’s already obsolete. The first time I copied it exactly. Three of the four stages require different settings now. I read through all the API docs and found where the differences were, made the changes, and then got 400 error instead. I tracked that down. Aron’s database used {_id} after the collection items, but I saw an answer to another post to the Parabola community that {id} should be used, no _underscore. That didn’t work, but I noticed my database has a capital “I,” which I didn’t try at first because I wasn’t sure if it was case sensitive or not. {Id} worked. It is case sensitive.

Now I get the 401 error, which tells me that the above issues are fixed, at least. That’s when I found that I had to type in “accept-token” because it’s not part of the drop down menu. I found that nugget in the API docs. Earlier I had tried “accept” and “authorize” and even “x-api-key” when I was receiving back 404 errors. Finally I discovered that I had to type it in, and it wasn’t clear that I could, but it finally took my third attempt.

So, Aron asked if I had the proper Collection ID, and I had copied/pasted directly from Postman, and had earlier used the same ID in a Zapier function, so unless Postman is giving me the wrong information, it should be correct. He suggested I ask the community. I then tried the Password Authorization, and that failed. The 0-auth looked daunting, but I gave it a try. I went to the Webflow account and authorize Parabola, got the secret passwords, and put them in the 3 step modal, and it all seemed to work, a pop-up window came up and said it was all authorized, but then I couldn’t close the Parabola modal window without it saying I was going to loose all my changes! When I closed it, all the data I had input into those 3 fields was gone, and I had to start over - 3 times!

That’s were I give up. I need some help. I can not figure this last step out. at. all.

Hey Danny!

Happy to help you get this export figured out, but you are using an older method of exporting to Webflow. Is there a reason that you are using the API Export and not using the new Webflow Export?

The authorization process and exporting controls are a lot easier to use on the new one! Just search the sidebar for Webflow Export and grab one.

I had seen a Webflow Export mentioned, but was not aware that it was different from what was used in the tutorial recipe. I will give it a go! I was only using the methods outlined in the video tutorial because it did exactly what I needed it to do.

Ah okay totally makes sense! I think there is more that we can do to inform folks that some of the recipes use older patterns and steps!

The new way (Webflow Export) was so much quicker and easier. Worked the first time!