Webflow pageviews field not updating, the flow works otherwise?

Hi, we have been running a PageViews update from Google Analytics to Webflow CMS for a couple of months now, for a filtered Most Popular Posts search. We have noticed that the site is getting more and more page views, but that the Most Popular Posts are returning the same result as when the flow was first created almost 3 months ago. That is because all the PageView fields in the Webflow CMS are empty!

The flow looks good, all the Google Analytics data is there with the PageViews count. Webflow CMS import is pulling in all that data. There is a Filter and a Sort that don’t really seem to be doing much, but I followed a Recipe that included them. I checked and double checked everything this morning. The Recipe runs successfully, but the PageViews fields in the Webflow CMS are not updating. The recipe is supposed to GET the Google Analytics ga:pagviews and Parabola is supposed to merge that with the Webflow CMS and PUT the data into the pageviews field. It’s running, but not updating.

I am at a loss as to why this isn’t working? I am running the flow that was updated at the end of April-early May.

Any help is appreciated, Adrien and Danny

Hey Danny!

I suspect that your Join is not joining any data successfully.

In that recipe, it is using an older version of the Find/Replace step, which can be confusing. In yours, you will want the Find and Replace step you have to essentially remove the first part of the URL. So in the recipe, the URLs are start with /essential-guide-to-airtable/ and then after that is the important slug which matches Webflow.

In your flow, make sure your Find and Replace step is finding /whatever-your-urls-start-with/ with slashes on both sides, and replacing it with nothing. Just leave the replace field blank.

You will know this is working if you look in the Join step you have, and look at the far right two columns from GA, and see that they are not blank.

Thanks for responding so quickly, I will give it a shot! I was wondering if I needed to populate that field with a ‘0’ or something instead of leaving it empty, because it was returning ‘null.’

Interesting - if you see that null again, can you post a screenshot for me?

Hello Brian,

So I looked at the Find/Replace and it looks like it’s doing what you suggested already, unless I misunderstand? I looked for a newer Find/Replace widget in the sidebar, but when I added it, the functionality seemed the same as what I am using, so I guess I couldn’t find a newer version?

I did try a few things, but none of them changed anything downstream, still blank ga:pageviews and ga:pagetitle.

I changed the Join from Webflow CMS to Find/Replace though, and that did change 2 things. It did populate the ga:title and ga:pageviews, but it also cleared out the ID, so it broke the flow for the Webflow Export downstream.

I thought the “null” was in the “pageviews” field, not the “ga:pageviews,” in the Join results, but its actually the “pagecount” field in the Webflow Export.

Okay, I played around with a bunch of different settings on each step, and when I got one working, I moved on to the next, and now it is finally populating the Webflow CMS pageviews! the settings don’t look much like the examples in the recipe, but at least it’s working!

I might have had it working sooner than I thought, but I forgot that the updates are stored as drafts and need to be published, so it wasn’t until I published the site fro Webflow that the Popular Posts changed.

The above “null” in “page-count” are all numbers that correspond to the “pageviews” now.

Glad you got it working! I took a peak at your flow and it is working now, using the page titles for the join. But in your find replace, if you remove the slash from “replace with” field - and leave that blank - you would be able to join the page path to the slug.

Thanks Brian,

“if you remove the slash from “replace with” field - and leave that blank - you would be able to join the page path to the slug.”

That is one of the things I was confused about. I had an asterisk * as a wild-card, in the original flow, but you mentioned there needed to be a backslash. Whenever I would try to remove the asterisk, it wouldn’t run, or it would replace the asterisk. It wouldn’t let me leave it blank, so I used the backslash and that at least gave me a result I could work with, though as you noted, not the intended one!

As I mentioned above, I just kept trying different settings to get one that worked so I could troubleshoot the next step, and that turned out to be “page-titles.”

I will give it another try using the “page-path” and slug, but at least I have a working fallback if it doesn’t!

Okay, I did the above and got it working!

Previously I had been editing the values in the original Find/Replace fields, and it kept reverting. This time I created a new field and left the replace with value blank and then deleted the original, since it did leave the value blank and didn’t add anything in place.

Then I was able to return the Join to Slug and PagePath, and everything is running as expected!

Thanks Brian!