I can't do a basic pull request to Bubble.io

Hi there.

I’m just starting with parabola (I want to export a Bubble’s database to google sheets).

I’m following several tutorials to set it up, but i don’t get pass step one, which is creating a successfull connection to bubble.
This is the video i’m following:

I tried it doing it with an app in bubble, and started againg with clean new table.

I can’t even retrieve the data without setting authorization parameters. For what i tested in integromat, When i add constraints to the request, it then provides data, but without it, it won’t.

You can find attached also my settings in parabola.

Any clue on how to set this up properly? Thanks in advance,

Hi @Uncovercity- Happy to help! Looking at that screenshot that you sent over, I see that you have None listed for the Authentication type. You’ll need to use a Bearer Token authentication in that section and enter your API key.

It also looks like you’ll need to reformat your API Endpoint URL. The example that you sent over should look like this: https://uc-experimentos.bubbleapps.io/api/1.1/obj/casas

If you’re still running into issues after making those changes, let us know!

Hi Emory. Thanks for your reply.

I didn’t set the requirement in Bubble for authentiation, so i shouldn’t need it in parabola to retrieve data. I have tried also setting this requirement, and setting it also in parabola, but i get the same result. So i took it out to make get request as simple as possible.

Also, the end point you are suggesting is for “production data (or live data, as bubble names it)”, but any request should also work for the test environment, so, in theory, that end point should be working.

Any more suggestions? Thanks!

Hi Javier,

Just checked out this Bubble thread and did some testing on my end. It seems that Bubble no longer exposes an API unless you’re on a paid plan.

Can you confirm if you’re using the Free plan?

Additionally, you mentioned you were able to pull in data in Integromat. What endpoints, constraints, and authorization parameters did you use?

I did modify the endpoint by adding the /casas typename after the obj. The API returned a response that also alludes to the subscription tier:


This application does not expose an API. Please upgrade your Bubble subscription for your API calls to run.

Let me know if any of this helps! Feel free to email us with some test credentials if you’re on a paid Bubble plan and need assistance troubleshooting.