Google sheets connection issue

Hi, I’m having no luck connecting with google sheets. I’ve tried deleting it. reconnecting. different accounts but still receive the following type of error.

“Error: Invalid values[35][30]: struct_value { }”

Any guidance on what might be causing this would be much appreciated!

adding to this, refreshing the data removes the error and running the flow brings it back.

Ive tried with an empty/new sheet also and same error occurs

Hey @Dave_Legion!

Thanks for providing details on the error you’re seeing. First, I recommend verifying if you have editor access to the Google Sheet you are trying to pull in. If you have editor access however the file is still not pulling in, I recommend some trouble shooting steps below.

  1. reauthorize the Google account in the step. You can do so by opening the step, click Choose accounts in the upper left corner, clicking edit, then removing the current Gsheet connection and adding a new one. At the time of re-auth, make sure that the account being re-authed has access to the Sheet you are trying to connect to.

  2. replacing the step with a new one from the sidebar. You’ll want to delete the existing step, and drop in a new GSheets step from the step from the side bar.

If you are still seeing an error pop up, our support team can help take a further look if you can email the flow link to

Hope that helps!

Thank you for your quick response. I have tried both these and re-authorised as the account holder but to no avail.

Copying in Ayana’s fix here for those who encounter similar issues:

"I was researching the error and found this thread. In short, it sounds like to prevent those errors, dates should be convert to Unix first, then whithin Gsheets apply a date format.

You can convert dates easily in Parabola by utilizing our Format Dates step."