Configuring Front Integration

Hi all,

I’m using Parabola to pass data from Front to Google Sheets. The flow is functional for short periods of time (~4 hour stretches) but I’m repeatedly getting errors due to my token expiring. (Image included!) I’m assuming this is some sort of Front auth token?

Is there something I can do through Parabola or Front to fix this?



Hey Nelson,

Are you using OAuth in Front?

I haven’t had a chance to dive in much, but found some info about expiring and refreshing tokens here.

Hey @Nelson_Arnous :wave:

While you can configure Front’s OAuth2.0 process in Parabola (we do support Authorization Code Flow), their API only requires OAuth when launching a public integration. If you’d like to pass data from Front to Google Sheets, you should be able to authorize with just a bearer token from Front.

We recently put together this “Front Configuration Card”, which you can use to access some of the most common Front endpoints. Simply paste this snippet into your flow (how to paste a snippet), select the step containing the endpoint you’re interested in pulling data from, and insert your Bearer Token into the Authentication section of the settings.

Here is the snippet that you can paste straight into your editor: parabola:cb:e18b2975ea764c5d811bdf5638e47e7f

Feel free to post any additional questions in this post – hope this helps!


Thanks Brian! Will give this a shot, really appreciate the (super fast) help :slight_smile:


Thanks to Adam and the Parabola team for a ready to go snippet on this!


Hey Adam! Thanks again for the last reply. New one for you :slight_smile:

So I’ve successfully accessed the Front API using the Configuration Card you shared (really great by the way). But I’m hitting a row limit as I try to pull event data from Front. Specifically, it looks like I’m only able to pull 2500 rows from Front at once.

I’m guessing this is probably a pagination problem. So I’ve tried to configure the ‘Pagination’ section of the ‘Get Front Events Since Certain Date’ widget based on Front’s pagination documentation (link)

Any advice?

Hey @Nelson_Arnous,

Really glad to hear the configuration card was helpful! Referencing the pagination info for their Core API, we can add pagination using these settings:

The next step is to increase the “Maximum pages to fetch” under “Rate Limiting.” For me, increasing this number from 6 to 7 increased the rows returned from 300 to 350. You can make this number however high you need to return all results.

I’ll be sure to update the configuration card to include this additional info – thanks for helping us improve the card! Let me know if you have any other questions.

Thanks Adam! I’m stumped again – seems like there’s a page limit of 9 pages, at 50 results per page (see below). Feels odd because that caps the query at 450 records (vs. I’d pulled 2500 without pagination before). Any thoughts? Really appreciate the sustained help on this!!

My pleasure @Nelson_Arnous!

Appreciate your patience with the back and forth – we did some additional testing on our end, and think we are now good to go!

Let’s first try decreasing your “Maximum requests per minute” to 50. According to their rate limits documentation, rate limits begin at 50 and can be increased depending on your plan.

As for the Pagination settings, you can try out “next” as the cursor key, and “” as the cursor path in response. We ran into the same 502 error before making this change, but now are able to successfully pull in additional pages.

The last step is to add “_results” as the “Top Level Key” under “Response JSON” to help unpack the data returned. Here is a look at our settings:

If you are able to successfully pull in data with these settings, I will update the above info people who come across this post in the future – let us know how it goes!

That worked perfectly! Really appreciate