Bearer token with x-api-key - 401

I cant connect to the Retail Express API using Expiring Tokens
I have setup the POST request type in the Account

The help docs for Parabola say that the token will be passed as a bearer token by default, however I am not seeing this in the requests. I have tried configuring the Advance Options in the account to show the token, and also the Bearer token setting in Authentication. Still no luck.

The instructions from Retail Express are:
Requests to other endpoints in the API must include this token (in the Authorization header parameter) and the API Key (again in the x-api-key header parameter):

Authorization: Bearer eyJhbmdWxsX2FjY2VzcyJdfQ.IWPofNEfIu-xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
x-api-key: hkldfhTYDnhlkadsfadsdfTYSDFNFDSF

Once a token expires, the same call to the Authentication Token endpoint is required to retrieve a new token. Once a token has expired, or if an invalid token is passed, a 401 Unauthorised response will be returned.

When I add the token in manually as Bearer XXXXX… it connects fine, however I cant seem to pass the token into the Authorization header

Hi @JamesF - Happy to take a look! It looks like they are returning the token as “access_token”. If you update the Advanced settings like this, do you see the API connecting?

Screen Shot 2023-04-03 at 1.03.51 PM

If not, could you please send over a link to your Flow to so we can take a look at how that authorization is set up?

Hi Emory
I had tried that, and get an error when trying to authorise.

I have sent through a link to help