Xero authentication: putting access token into API requests

Hi, I’m trying to link up an API data pull from Xero.
I think I’ve set up my Account/OAuth correctly - when I click authorize it opens a Xero popup which I confirm, and then it takes me back to Parabola and I can’t see any errors.
But now if I want to actually make a GET request, the Xero documentation says I need to provide: "Authorization: “Bearer " + access_token”.
How do I add the access token from OAuth to my GET request?

Hey @Jacob_Monash,

Thanks for reaching out. Since it requires you to authenticate via OAuth 2.0, you need to select that as your authentication type.

We’ve had mixed results integrating with Xero, but you can try adding a custom Authorization header to see if that works:

Checking if you had any luck with this? I am trying to do the same.

I am getting a connection using your OAuth 2.0 option, yet Xero replies “OAuth 1.0a support is currently being removed. You must use OAuth 2.0.”

Hi @Andreas_Marinopoulos – Unfortunately we are currently unable to integrate with Xero. Their OAuth2.0 setup is not quite aligned with ours, including additional requirements not supported by our step.

Wish I had a better answer for you here!