Google Analytics time frame pulls more data than I specify

When I pull data from Google Analytics and specify the time range as “September 1 2020 and September 30 2020”, the months that get pulled through always include October in my “Month of the year” row. What is the cut off on the last day? 11.59PM? This also happens when I use “within the previous 1 month” time frame too. Any help is appreciated. ThanksScreenshot 2020-10-07 at 3.54.48 PM Screenshot 2020-10-07 at 3.55.23 PM

Hi @Matthew_Sartain - Thanks for posting about this. Interesting. I just tried reproducing this issue, but wasn’t able to.

We pull in and use the same time zone that is set for your Google Analytics account. You can double-check what that is on the “View Settings” page under “Settings”.

Based on your screenshot, it looks like we’re pulling based on CDT time zone. Just for troubleshooting, if you set the range to August 1-August 31, do you see any data where Month of the year is 09?

Hi @sachi, thanks for your quick response. My time zone settings in Google Analytics are set to GMT -5 (CDT). When I change the time frame to August 1-August 31, I do get 09 pulling through. When I add in day of month, any 09 month is only ever the 1st day.

Any help you can provide is appreciated - I’m looking to run quite a few flows a month and this issue is going to prevent that.

Thanks

Thanks for the additional info. I’ve asked our engineering team to help us look into this. I’ll follow up as soon as I have more info!

Just a quick update here, @Matthew_Sartain. Our engineering team did find an issue with how we’re requesting dates from Google Analytics. We have a fix up for review and it should be going out sometime tomorrow. I’ll follow up here as soon as it’s resolved. Thanks for flagging this with us!

That’s great to hear @sachi, thanks. I was wondering if you’d be able to reset the credits on my account - I’ve used 13 of the 15 free credits just testing a script in Google Sheets that was circumventing this bug.

Thanks for your help.

Good news! Our engineering team just released a fix for this. Check it out and let me know if you see any other issues.

We’ve also gone ahead reset your credits for this billing cycle.

@sachi Thanks for resetting my credits, when the time frame is set to specific dates - sept 1st to sept 30th, the issue is resolved but when I use “within the previous 1 month” I still see the same issue.

Thanks for the heads up. Interesting. Can you screenshot what’s showing up in the date range that appears at the bottom of the step settings when you have that particular configuration?

Thanks for the screenshot. Synced with our Eng team on this. We understand what’s happening. It’s a particular problem with our Google Analytics step because it’s the only on our steps where we send dates to Google (which Google requires), not times.

We’ll address this and should have a fix for it early next week. I’ll follow up with you. Thanks for your continued patience with this one!

Hi @sachi, any update on eta for the fix?

Thanks.

Thanks for checking in. The fix is in review right now. Should be coming out in the next few days, but will follow up with you as soon as it does.

1 Like

Hey @Matthew_Sartain - the fix has been released! I tested on my end and it looks good. Can you let me know how things look on your end?

Looks all good to me @sachi . Thanks for your help on this, I appreciate it.

Awesome! Glad to hear it. No problem, always happy to help.

Hi again @sachi , one other question - is it possible to connect a flow to a shared G drive for the creation of a Google sheet? I can’t see an option to but don’t want sheets sent to my own drive.

Thanks

Hi @Matthew_Sartain, at this time it isn’t possible to connect a flow to a shared Google Drive. This is on our radar and is something we’d like to support, so we’ll send out an update in the future if this is added.

That’s a real shame, it would be extremely useful. Thanks for your reply.