Error says "column does not contain numbers" but it does

Trying to use Sum by group to add together money amounts per product. Except it’s saying that the column I’m trying to add doesn’t contain numbers. It does contain numbers as you can see below, although they have decimals — is that throwing Parabola off?


Hopefully we can fix this, or you can tell me another way to sum up my royalties. Need to be able to add up sales for basic analytics :slight_smile:

I need a workaround for the meantime. I can use Merge duplicate rows to get all the royalty numbers in the same cell, but I’d then need a Parabola transform or regex formula that will sum all the numbers in that cell — which would be separated by commas due to the way Merge duplicate rows works.

Hey @Nathan — this should only happen if Parabola can’t recognize some of the values as numeric. Try using the Format numbers step and see if that successfully coerces the data into all numeric values? Alternatively, feel free to shoot us a note with a link to the flow at and we can help you debug.

That worked! Thanks Andrew :slight_smile:

Even though I’m all set now, I would propose that the numbers I screenshotted above should be readable as-is. But I’m aware I may be a fringe case and Parabola no doubt has many things on their plate.

Anyway, thanks again.

Totally agree. Will flag for the team.

Did you end up figuring out what characters were throwing it off?

No clue, but I did find it interesting that Sum by group could not read the numbers despite being a math function, and Format numbers read the same numbers without a hitch. Maybe there’s something to steal from Format numbers and put into Sum by group.

I ran a test — I think it’s decimals. In the Clean Up transfer, Parabola counts decimals as non-number characters (there should be a new option all non-number characters except periods). So Sum by group probably sees them as non-numbers as well. Especially considering that after using Clean Up to remove “non-number characters” i.e. the decimals, Sum by group runs without error. That narrows down the bug I think.

Appreciate the investigation here @Nathan! I created a bug ticket internally with this information to put the issue on our team’s radar. Glad to hear the Format Numbers step did the trick in the meantime.

1 Like