API fetch error - application/json is not supported

Receiving this error. Works fine in postman.

It’s a post req.

“errors”: [
“code”: 415,
“message”: “application/json is not supported for report REPORT_CALCULATED_TIME_ENTRY_SUMMARY”
“user_messages”: [
“details”: {
“code”: 415
“severity”: “ERROR”,
“text”: “application/json is not supported for report REPORT_CALCULATED_TIME_ENTRY_SUMMARY”

Any insight on what this might be and how to solve?

Hey Yahav,

At first glance it would look like your API does not accept JSON encoded body data in the request, which is the only way Parabola can send it.

Can you should me what your Postman set up looks like?

Not sure if this is what you are referring to, but take a look - simply an empty object {}. I Put that in the api input here as well.

Hmm okay, and can you share a screenshot of your API step in Parabola? With any private information redacted

Does it work in Parabola if you remove the Content-Type header?

It’s does not. It’s a req header.

Are you getting the same error? That header is set automatically by Parabola, so I could see setting it again causing issues.

Tried running it with it removed. Same error.

Can you email me the URL to the flow so that I can take a closer look at it? Send it to help@parabola.io

Thanks for sending that over!

Set your Content-Type header to application/json - I think there is a typo in it now

And set a new header called Accept with the value csv

Accept csv did the trick.
Many thanks.