Salesforce reports not pulling data

After linking salesforce into the pull data step, selecting a report doesn’t pull any data upon hitting the refresh button.
I’ve tried with multiple different reports and it doesn’t seem to be able to get any data pulled.

I have looked at another flow that I’m pulling report data and the report name is showing up as the specific id of the report, rather than the name. I tried inserting the report ID into this new flow but it won’t find it in the list of reports available.

Any insight?

Hey Yahav!

It seems that Salesforce API does not support grabbing all reports, it only supports grabbing recently updated reports. Are your reports by chance not under the recently updated reports tab?

If there’s a specific report you’re trying to pull in, we recommend saving an update to the Report so that it may populate on the recently updated list. If that doesn’t work for you, feel free to send an email with your flow link so we can take a further look.

Thanks! Ayana