CSV Output Format

I have two questions.
First, I chose CSV file output and it emailed the file but it is not in a CSV format. Is there a setting I’m overlooking?
As I’m using several flows and they’re all sending CSV files I’d like it to show the CSV Export Frame Name I gave it in my flow, that would be very helpful.
Thanks

I am also looking for a way to change the default delimiter. Right now it seems only comma is possible, while standard, as far as my experiance goes, is semi-colon.
I have lot’s of data where specific columns have comma seperated values, like keywords, tags and such.

So, in addition to the desire to create a unique name for each CSV output (somewhere beyond the flow itself) the “Download CSV” link emailed to me no matter of how I try to save or open it this is the contents:
{“data”:{},“error”:“Invalid User”} and the email contents state this is a 24 hour link but I tried to open it within seconds and got this result.
I’d like to be able to 1) Set a unique name so that the email gives me a clue for which Flow it’s from more than “Shared CSV Data”
2) I’d like to not have to go into Parabola and each flow then open Excel to open the Txt/Csv download so I don’t have to rename it first. (Extension of number 1)
Thanks in advance.

Hey Link!

  1. The CSV export should certainly be sending files in CSV format! Are you getting an error elsewhere that the file you are getting is not a CSV?
  2. You can rename the CSV file by renaming the CSV Export step. That can be done by double clicking on the name of the Export. That name, however, only shows up once you download the link.

For this one, you can only download the file from a browser that is logged in to Parabola - so that we know you are authorized to access that file! You may be seeing this if you are downloading from a browser that is not currently logged in to Parabola.

Hey Mitja,

Feel free to post a feature request for changing the delimiter over here! https://community.parabola.io/c/product-feedback/feature-requests/12

Currently you can Import data with other delimiters, but cannot export with anything but a comma as the delimiter.

OK, to be clear, you’re saying the name at the top left of the flow just add “.csv” to the name inside the frame when I click to open the export tab in the flow? That’s easy enough.

Hey Link, I am not - you can place the name you want your file to be in that slot - such as Sales Report and then when it runs, and you download the file, you should get a file called Sales Report.csv - is that not happening for you?

If I download the form straight from the results on the right of the flow it is a txt file. I either have to start Excel and open then save it or I have to rename it something “.csv” . It’s not just coming out as a simple csv to use as I want. It’s not the end of the world but it’s a little annoying that I’ve spent quite a few hours trying to get the output right to now have to manipulate it further.
Ultimately I plan to link an API on a couple things but right now I’m just using parabola to reorganize data and this is adding a step.

That is odd! It downloads as a .csv file for me. What operating system and browser are you using?

No. It is a Txt file. I have to open Excel to open and then save as a csv or rename it as a .csv file.

Windows 10 and both Firefox and Chrome.

Hey Link! Super frustrating to hear about the .CSV export saving as a .TXT file. I spoke with our team and they informed me that we are only able to hint at what the save file should be, in this case .CSV, of course. Unfortunately, browsers and operating systems can override this recommendation, and from there it’s out of our control.

I found that a similar issue also happened to a user at Unbounce. Have you tried changing the way your computer associates .CSV files? You can do that by right-clicking on your file and select “Open With”. You should see an option to choose Excel as the program that opens the file and also be prompted if you want all .CSV files to be opened that way.

If it is actually saving as a .TXT file and not just opening the .CSV in Notepad, then just let us know and we’ll have our team look into it further.

Hi JP. I appreciate you digging in to this. Actually I use Excel 365 so it doesn’t open files unless I open it first. I can save the download as or go in to properties and change the file to a name.csv both of which work it’s just an extra step. As I said earlier
I can do but it’s just an extra step I’d prefer to avoid but Parabola so far has been a time and money saver so I’m ok.
I intend to link as much as possible with APIs but that’s beyond my scope at the moment :woozy_face:.

1 Like


I printed the screen and you can see it’s saving it with csv as a name but it’s saving as a TXT file format. Really weird.

Hi Link,

Thanks for the screenshot! Are you able to right-click the file and select “Open With”? It appears that it’s actually saving the data correctly, however your computer does not know which program to use to open it y default. This can be solved by right-clicking and selecting Open With and clicking Excel (example screenshot below). You may see another option to then set Excel as the default program for this file-type.

image

Inherently, CSV files are actually just comma-separated TXT files. If your computer does not know that you’d like to always open this file type with Excel, it will default to reading it as a TXT file and presumably open it in Notepad. Is that what is happening to you?

Im familiar but as I mentioned yesterday that I use Excel 365 so unless excel is open my computer doesn’t allow that as an installed option.

Hey Link,

Got it. I’m not too familiar with Excel 365 or Office 365. Could you possibly download Excel directly to your computer while you try this solution from Microsoft’s community?

https://answers.microsoft.com/en-us/windows/forum/all/i-want-excel-to-be-the-default-app-to-open-csv/7390de35-c424-4870-bc8f-8a239d9f5edd

After that, perhaps you can go back to just using Excel 365, and the files will open by default.

I believe this is a file-handling issue with your computer and Office 365, and most likely not a Parabola error, so I may not be able to provide much more guidance than I have thus far. Really sorry that I couldn’t be of more assistance!

2 Likes