"Missing required parameter: redirect_uri" error during OAuth setup

Hi team!

I’m trying to connect to the Spotify API but I’m getting a “Missing required parameter: redirect_uri” error. I’ve followed other posts here in the forum and thought I had set it up correctly :frowning:

Does anyone have an idea where I might be going wrong? Thanks for your help!

Hi @Isabel :wave:

Welcome to the community! Happy to help get you sorted out here. One thing to note is that you’ll also need to provide the redirect_uri directly to Spotify in your developer dashboard.

To do this, click into your application and select Edit Settings. Under Redirect URI, add the generic callback URL provided by Parabola and save your settings.

Let us know if that helps!

******* EDIT*******

I was trying to use redirect-uri instead of redirect_uri whooopsieee

Hi @daniel! Excited to be here!

I had done this actually :disappointed: I just refreshed it just to be sure but the issue prevails.
Super grateful for any other tips! :pray:

Hi @daniel,

given I eventually made it work, I’m surprised that the same OAuth setup isn’t working for posting to the API. I’ve included all required scopes but I’m running into a 403 error “Insufficient client scope”. According to Spotify’s documentation this is due to missing authorization. Any idea where I might be going wrong? Any tips from this project? Thank you

Hi @Isabel,

Glad to hear it worked! Regarding the 403 error, can you check your Send to an API step to ensure the same account credentials are being used from your Pull from an API step?

If you’ve tried to authorize multiple times, there may be duplicate account permissions linked to that step from each failed attempt.

Let me know if that helps!

Hi @daniel,

Yup, turns out I had bunch of duplicate account permission! I’ve cleaned it up now making sure I use the same credentials for send/pull. I double-checked the scopes too but still no luck. :disappointed:
I tested adding items to a playlist through Spotify’s web console and it worked – is there anything in their curl command that I’m missing?
For reference, this is the documentation I was using and below is my setup. Thanks again for all your help :slight_smile:

Thanks for checking that, @Isabel! Are you updating a private or public playlist?

Taking a look at their documentation, use the scope playlist-modify-public to modify one of your public playlists.

To modify one of your private playlists, use the scope playlist-modify-private.

Double-check to ensure you have a single scope defined. Let me know if that helps!

Hey @daniel, thanks so much for your help over the past couple of days.

I finally made it work! It’s embarrassing to admit… turns out I had another typo in the scopes! :see_no_evil:

Have a great weekend :beers:

1 Like