JSON Flattener step is highlighted red: "Failed to calculate"

Hi there!

In my flow, I have a JSON Flattener step which is consistently resulting in the following error:
“Failed to calculate: The step failed to calculate. Please try again.”

I have tried it several times over 2-3 days and I have tried reconnecting the step. Sometimes this error manifests as the step being highlighted red and perpetual “Calculating…” which went on for several hours until I stopped it.

The errored JSON Flattener step is preceded by another JSON Flattener step which is providing an input of 408 rows and 36 columns. The field to be flattened on each row has 52 objects consisting of 4 attribute-value pairs in each object. I believe this should result in about 21,216 rows after flattening.

For example, it has one of these objects for each week of the year:


The objects are enclosed in a set of brackets to indicate the array .

Do you happen to see where I may be going wrong? I have successfully used JSON Flattener in similar ways elsewhere in this flow, so this error is strange. Thank you!

That does seem odd! I can’t reproduce it on my end, though. Can you email me the URL to the flow where this is happening? Send it to help@parabola.io and I will see if I can sort it out and report back here!

Thanks a bunch! I just sent you the info.

Just to follow-up here, I was able to get this working by placing a ‘Remove Columns’ step before my ‘JSON Flattener’ step for the purpose of reducing down from 35 columns to the 11 that I actually need. This made the step run quickly and it completed successfully. Thank you!

1 Like