How to add a parameter to the the base endpoint?

Hi there,

I have a rest API that I want to use but the parameter needs to be added to the base url (before the ?).

It’s a PATCH request type and should be something like this:

I know how to add the variables like api_key and for the request body, but the same principle doesn’t seem to work for the base endpoint.

Is anyone facing the same issue or is just me missing something?

Hey @Bruno, Welcome to Parabola’s community!

Is the API endpoint you’re trying to connect to an expiring access token auth or OAuth2.0? If so, you should be able to set those up as an auth instead of inputting the parameters in the URL directly! If you aren’t sure which type of auth method your endpoint is, feel free to share with us the API Docs and we’ll be happy to take a look. You can email it to if you’d like.

If the variable needs to be fed in from another source (ex Google Sheets), you’ll want to use an Enrich with API step. This step currently only processes requests as GET and POST. If those methods work, in the step settings, the Variable Column name will be inputted inside curly brackets {} as such into the url:{Variable Column}?api_key=YYY

Let us know if you have any other questions!

Thanks @Ayana_Usui for your quick reply.

The API endpoint I am trying to connect to is using username and password authentication. “Enrich with API” is not a solution because as you said, it supports only GET and POST requests and I am dealing with a PATCH.

Would you mind sharing with us the endpoint you’re hoping to connect to so we can take a further look? If you’d prefer, feel free to email us those docs at